Commerce Database

Jun 1, 2010 at 5:07 PM

Just started with the first video. I built the project, added the images, but when I try to attach the COMMERCE.mdf and COMMERCE_LOG.ldf to my database I get the following:

Unable to open the physical file "D:\Development\MyTailspinSpyworks\MyTailspinSpyworks\App_Data\Commerce.mdf". Operating system error 5 "5(Access is denied)". (.Net SQLClient Data Provider)

If I can't download the associated database files can I get some scripts and data to build the database?

Thanks in advance!

Coordinator
Jun 1, 2010 at 6:49 PM

Did you try correncting the permissions issue ?

Jun 2, 2010 at 5:38 AM

No. Where do I find information on " correncting the permissions issue"?

Coordinator
Jun 3, 2010 at 4:32 PM

That's a HUGE question.

You could start here. http://blogs.msdn.com/b/sqlexpress/archive/2006/11/22/connecting-to-sql-express-user-instances-in-management-studio.aspx

Try starting Visual Studio as admin and see if that works and if so we'll know that your regular account lacks file permissions.

Jun 4, 2010 at 3:58 PM

Running VS 2010 and SQL 2008 as administrator worked like a charm.

Of course I'm not sure why since my account type is administrator that I have to rum applications as administrator makes any sense, but the more complicated thay make the more they needs us and the more they'll have to pay us! Now I have to figure out why and what I can do to not to have to run things as administrator on my own machine when I am an administartor.

Thanks for the help!

Jul 16, 2010 at 2:54 PM

I am also having trouble accessing the database would it be possible to have the scripts to enable us to create the database from scratch

Jul 16, 2010 at 2:55 PM

It is telling me that the version downloaded does not match with the version loaded on my visual studio 2010 version

Coordinator
Jul 16, 2010 at 2:58 PM

Are you using SQL 2008 ?

Jul 16, 2010 at 6:08 PM
Yes visual studio 2010 with sql 2008


From: [email removed]
To: [email removed]
Date: Fri, 16 Jul 2010 06:58:13 -0700
Subject: Re: Commerce Database [tailspinspyworks:214596]

From: JoeStagner
Are you using SQL 2008 ?
Read the full discussion online.
To add a post to this discussion, reply to this email (tailspinspyworks@discussions.codeplex.com)
To start a new discussion for this project, email tailspinspyworks@discussions.codeplex.com
You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.
Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com


Get a free e-mail account with Hotmail. Sign-up now.
Jul 19, 2010 at 12:35 PM

Just a quick note,

While going through the vids, I noticed that one of the view modules in the commerce db is misspelled

it is named "vewOrderDetails" instead of "viewOrderDertails", it is missing the "I" in view.

among a few other small tidbits which can be easily corrected, that actually gave a lot of wiered and unrelsted errors at times.

Still working on the rest of the VB version, sorry its taking so long but I'm kinda busy with other projects.

Jul 20, 2010 at 12:03 PM

It is telling me that the version I am trying to download is version 655 and my server is version 612 and there is no downgrade path supported

Coordinator
Jul 20, 2010 at 12:57 PM

The database is SQL2008 - you can insall SQL 2008 Express from http://www.microsoft.com/express/Database/

-Joe

Jul 21, 2010 at 10:15 AM
I have done a complete restore of visual studio 2010 and installed the sqlserver 2008 express and it is giving me the following error" Failed to generate a user instance of SQL Server due to a failure in starting the process for the user instance. The connection will be closed." What am I doing wrong


From: [email removed]
To: [email removed]
Date: Tue, 20 Jul 2010 04:57:33 -0700
Subject: Re: Commerce Database [tailspinspyworks:214596]

From: JoeStagner
The database is SQL2008 - you can insall SQL 2008 Express from http://www.microsoft.com/express/Database/
-Joe
Read the full discussion online.
To add a post to this discussion, reply to this email (tailspinspyworks@discussions.codeplex.com)
To start a new discussion for this project, email tailspinspyworks@discussions.codeplex.com
You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.
Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com


Get a new e-mail account with Hotmail - Free. Sign-up now.
Jul 21, 2010 at 1:52 PM

Barthoid!

I am getting the same error, I believe it is the JoeStagner user instance,

and that we can change through attaching the database to SQL managemnet studio and do the changes there.

I believe that "Beginners" should now about this pitfall and that if they try to copy the application to their local IIS wwwroot folder and

converting it to Application and try to run ít, then they will face these problems with the DB.

I am working on the VB version and I will try the C# version on my webroot when I am finished.

BTW go to VB discussion for the VB version, but remeber not to copy it to IIS webroot,

It will not work.

Coordinator
Jul 21, 2010 at 2:21 PM
basba is correct and you can assign your own WIndeows account permissions to the database in SQL Manager
Jul 21, 2010 at 5:28 PM
Edited Jul 21, 2010 at 5:29 PM
Hi Joe, Thanx, but I got a tiny problem and I hope you'ld have a suggestion, I have recreted the whole application from scratch in VB but now not as a file project but as an http: application in VWD 2010 However the build is perfect, I don't seem to get it to give a decent error that I can play with nor will it show up in the Iexplorer, and its teasing the heck out of me, I looked at the debugger, inner exceptions, logs everything and no clue. here is the build output Building directory '/mystore/Styles/'. Building directory '/mystore/Controls/'. Building directory '/mystore/Scripts/'. Building directory '/mystore/'. Validation Complete ========== Rebuild All: 1 succeeded, 0 failed, 0 skipped ========== Any ideas?
Jul 21, 2010 at 8:02 PM
Thanks, I must be a total beginner how would I go about changing it in the management studio.


From: [email removed]
To: [email removed]
Date: Wed, 21 Jul 2010 05:53:03 -0700
Subject: Re: Commerce Database [tailspinspyworks:214596]

From: basba
Barthoid!
I am getting the same error, I believe it is the JoeStagner user instance,
and that we can change through attaching the database to SQL managemnet studio and do the changes there.
I believe that "Beginners" should now about this pitfall and that if they try to copy the application to their local IIS wwwroot folder and
converting it to Application and try to run ít, then they will face these problems with the DB.
I am working on the VB version and I will try the C# version on my webroot when I am finished.
BTW go to VB discussion for the VB version, but remeber not to copy it to IIS webroot,
It will not work.
Read the full discussion online.
To add a post to this discussion, reply to this email (tailspinspyworks@discussions.codeplex.com)
To start a new discussion for this project, email tailspinspyworks@discussions.codeplex.com
You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.
Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com


Get a free e-mail account with Hotmail. Sign-up now.
Jul 22, 2010 at 1:57 PM

Ok Barthoid,

I will write a step by step soon

Jul 22, 2010 at 2:04 PM
Hi Joe, Thanx,
but I have a tiny problem and I hope you'ld have a suggestion for me,
 I have recreted the whole application from scratch in VB but now not as a file project but AS an http: application in VWD 2010
However the build is perfect, I don't seem to get it to give a decent error except for
A first chance exception of type 'System.Web.HttpException' occurred in System.Web.dll
a system.web.httpUnhandles exception message which is totaly Greek to me.
It simply won't show in the Iexplorer, but it starts it,
 its teasing the heck out of me, I looked at the debugger, stack and locals and inner exceptions (nothing), logs everything and no clue.
here is the build output and it is fine
 Building directory '/mystore/Styles/'.
Building directory '/mystore/Controls/'.
Building directory '/mystore/Scripts/'.
Building directory '/mystore/'.
Validation Complete ========== Rebuild All: 1 succeeded, 0 failed, 0 skipped ==========
So Any ideas?
I'd apprecite it.
Coordinator
Jul 22, 2010 at 2:29 PM

Hi Basba,

Can you send me a zip file with the solutin and I'll give it a look ?

Joe

Jul 24, 2010 at 1:03 AM
Edited Jul 24, 2010 at 7:11 PM

Hi Joe;

I have resolved the problem, there was nothing in the code or anything that I have changed in the DB ownership,

It simply was the freaging IIS. Though the ASPNET.MDF does give an error code when trying to create a user online.

Any how, you are welcome to look at the application if you still wanted to I will zip it and upload it as a personal patch to misfits.

It was nice of you to ask,

and thanx again for those vids along with the PDF tutorial I was aable to make a VB web app that can run

on localhost.

Truly

Bas

 

Jul 24, 2010 at 1:06 AM
Edited Jul 24, 2010 at 7:32 PM


Hello again and sorry about the belated reply,

Instance and Database

Check out this link

http://decipherinfosys.wordpress.com/2009/01/29/no-surface-area-configuration-tool-in-sql-server-2008/

Then do the following

Application Pool Identity is your problem.


If you changed the DB or have deleted the ownership and created your own ownership do the following to your IIS and this shoould solve your instance problem, it is just that Microsoft do not tell folks about the problem with their IIS and the new 4.0 development


Run the Internet Information Services (IIS) Manager tool.  This tool can be accessed either from the Administrative start menu, or by typing "inetmgr" in the Windows Start-->Search textbox and selecting the inetmgr tool.
In the left-hand pane of the IIS Manager tool expand the machine node.
Click on the "Application Pools" node so that the application pools display in the main window of the management tool.
If you are troubleshooting an ASP.NET 2.0/3.0/3.5 application select the "DefaultAppPool" application pool.  For ASP.NET v4 select the "ASP.NET v4.0" application pool.
Right-click on the selected application pool and choose "Advanced Settings"
In the "Advanced Settings" dialog box find the category called "Process Model".  The first row in the category will be the "Identity" row.
Click on the "Identity" row and then click on the small button that shows on the right-hand side of the value cell.  The button displays the text "…"
A dialog box called "Application Pool Identity" will popup.  Within that dialog box there are two radio buttons.  Make sure the first radio button titled "Built-in Account" is selected.
In the dropdown box below the radio button choose "Network Service" for the identity.
Click "Ok" to close out the "Application Pool Identity" dialog box.
Click "Ok" to close out the "Advanced Settings" dialog box.
At this point the changes to the application pool identity will have been saved to IIS 7.5's configuration store.

P.S. you can also set it to Local System and that will allow the creation of new users.

Truly

Bas

Jul 26, 2010 at 4:33 PM
Edited Aug 2, 2010 at 12:52 AM

Hello,

Please check the previous post for detailed info, and make sure that your server instance name is spelled correct ir Is the correct one, like .\SQLEXPRESS or .\MSSQL or just plain dot ".", like in local default instance.

You may also have to omit the User instance = true from the Commerce.mdb connection string and add a localsqlserver connection with the user instance = true with the aspnetdb.mdf connection, and make sure that the ApplicationServices has one too for the membership in the web.config which should have already made one for you when you have set up the users and memebership, but check it anyway. here is a working example

<connectionStrings>
        <remove name="LocalSqlServer" />
        <add name="LocalSqlServer" connectionString="data source=.\SQLEXPRESS;Integrated Security=SSPI;AttachDBFilename=|DataDirectory|aspnetdb.mdf;User Instance=true" providerName="System.Data.SqlClient" />
        <add name="ApplicationServices" connectionString="data source=.\SQLEXPRESS;Integrated Security=SSPI;AttachDBFilename=|DataDirectory|\aspnetdb.mdf;User Instance=true" providerName="System.Data.SqlClient" />
        <add name="CommerceEntities" connectionString="metadata=res://*/App_Code.Commerce_EDM.csdl|res://*/App_Code.Commerce_EDM.ssdl|res://*/App_Code.Commerce_EDM.msl;provider=System.Data.SqlClient;provider connection string=&quot;Data Source=.\SQLEXPRESS;AttachDbFilename=|DataDirectory|\Commerce.mdf;Integrated Security=True;MultipleActiveResultSets=True&quot;" providerName="System.Data.EntityClient" />
    </connectionStrings>

 

Hope this will help fix the problem, I tried it and it works.

Aug 4, 2010 at 10:45 AM

I have re installed Microsoft SQL Server 2008 and tried to copy across the commerce.mdf files again and i still get the error message the version you are trying to copy is version 655, my server supports version 612 and earlier, and a downgrade path is not supported. What Am I doing wrong.

Aug 4, 2010 at 6:08 PM
Nothing, I don't think there is anything wrong with your SQL server, just make sure the server instance name is the same as in the connection string in web.config, and do me a favour here, use your windows explorer and navigate to the folder where you have your commerce.db at, and right click on it and tell me if it says BLOCKED. You have to follow the instructiions in my previous posts.
Aug 5, 2010 at 1:53 PM
To be honest I have given up I tried to reinstall sqlserver and I cannot even create a data base from scratch now the f#~king bag of S*@t program,


From: [email removed]
To: [email removed]
Date: Thu, 5 Aug 2010 04:22:26 -0700
Subject: Re: Commerce Database [tailspinspyworks:214596]

From: basba
Nothing, I don't think there is anything wrong with your SQL server, just make sure the server instance name is the same as in the connection string in web.config, and do me a favour here, use your windows explorer and navigate to the folder where you have your commerce.db at, and right click on it and tell me if it says BLOCKED. You have to follow the instructiions in my previous posts.
Read the full discussion online.
To add a post to this discussion, reply to this email (tailspinspyworks@discussions.codeplex.com)
To start a new discussion for this project, email tailspinspyworks@discussions.codeplex.com
You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.
Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com
Aug 5, 2010 at 5:40 PM

I know how you feel at times I felt like throwing my laptop in the dumpster, but I hear ya.

At one time I had to re-install a fresh Windows OS and then re-install all my programs from scratch.

Good luck.

Coordinator
Aug 5, 2010 at 5:44 PM
basba - could you emil me directly ? Thanks Joe
Aug 5, 2010 at 5:47 PM
Hey Joe, long time.
Wasup?
Bas

From: [email removed]
Sent: Thursday, August 05, 2010 6:44 PM
To: [email removed]
Subject: Re: Commerce Database [tailspinspyworks:214596]

From: JoeStagner

basba - could you emil me directly ? Thanks Joe
Coordinator
Aug 5, 2010 at 6:09 PM

Did you get my PM ?

Aug 5, 2010 at 6:13 PM

No,, could you send it again...

Coordinator
Aug 5, 2010 at 6:25 PM

COUld you email me at Joe.Stagner@Microsoft.com ?