Need help I can't get sample app to work.

May 4, 2010 at 7:13 PM
Edited May 4, 2010 at 7:15 PM

I think I got the reference to the Ajax contorl toolkit to work, but now I get another error in my build I just cannot figure out. I sure would like to use this app if someone can help me get it working. It builds without any errors but when I try to run it, this is what I get:

thank you in advance
rcla396

System.Exception was unhandled by user code
  Message=ERROR: Unable to Load Popular Items - An item with the same key has already been added.
  Source=BizDevTrainingVideos
  StackTrace:
       at TailspinSpyworks.Controls.PopularItem.Page_Load(Object sender, EventArgs e) in C:\Users\DataSeek\Documents\Visual Studio 2010\Projects\Websites\BizDevTrainingVideos\BizDevTrainingVideos\Controls\PopularItem.ascx.cs:line 40
       at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e)
       at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e)
       at System.Web.UI.Control.OnLoad(EventArgs e)
       at System.Web.UI.Control.LoadRecursive()
       at System.Web.UI.Control.LoadRecursive()
       at System.Web.UI.BasePartialCachingControl.LoadRecursive()
       at System.Web.UI.Control.LoadRecursive()
       at System.Web.UI.Control.LoadRecursive()
       at System.Web.UI.Control.LoadRecursive()
       at System.Web.UI.Control.LoadRecursive()
       at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
  InnerException: System.ArgumentException
       Message=An item with the same key has already been added.
       Source=mscorlib
       StackTrace:
            at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
            at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
            at System.Data.Metadata.Edm.ObjectItemAttributeAssemblyLoader.LoadRelationshipTypes()
            at System.Data.Metadata.Edm.ObjectItemAttributeAssemblyLoader.LoadTypesFromAssembly()
            at System.Data.Metadata.Edm.ObjectItemAssemblyLoader.Load()
            at System.Data.Metadata.Edm.ObjectItemAttributeAssemblyLoader.Load()
            at System.Data.Metadata.Edm.AssemblyCache.LoadAssembly(Assembly assembly, Boolean loadReferencedAssemblies, ObjectItemLoadingSessionData loadingData)
            at System.Data.Metadata.Edm.AssemblyCache.LoadAssembly(Assembly assembly, Boolean loadReferencedAssemblies, KnownAssembliesSet knownAssemblies, EdmItemCollection edmItemCollection, Action`1 logLoadMessage, Object& loaderCookie, Dictionary`2& typesInLoading, List`1& errors)
            at System.Data.Metadata.Edm.ObjectItemCollection.LoadAssemblyFromCache(ObjectItemCollection objectItemCollection, Assembly assembly, Boolean loadReferencedAssemblies, EdmItemCollection edmItemCollection, Action`1 logLoadMessage)
            at System.Data.Metadata.Edm.ObjectItemCollection.ImplicitLoadAssemblyForType(Type type, EdmItemCollection edmItemCollection)
            at System.Data.Metadata.Edm.MetadataWorkspace.ImplicitLoadAssemblyForType(Type type, Assembly callingAssembly)
            at System.Data.Objects.ObjectContext.GetTypeUsage(Type entityCLRType)
            at System.Data.Objects.ObjectContext.GetEntitySetForNameAndType(String entitySetName, Type entityCLRType, String exceptionParameterName)
            at System.Data.Objects.ObjectContext.CreateObjectSet[TEntity](String entitySetName)
            at TailspinSpyworks.Data_Access.CommerceEntities.get_OrderDetails() in C:\Users\DataSeek\Documents\Visual Studio 2010\Projects\Websites\BizDevTrainingVideos\BizDevTrainingVideos\Data_Access\EDM_Commerce.Designer.cs:line 101
            at TailspinSpyworks.Controls.PopularItem.Page_Load(Object sender, EventArgs e) in C:\Users\DataSeek\Documents\Visual Studio 2010\Projects\Websites\BizDevTrainingVideos\BizDevTrainingVideos\Controls\PopularItem.ascx.cs:line 20
       InnerException:

Coordinator
May 5, 2010 at 1:00 PM

Did you try a clean rebuild ?

May 5, 2010 at 3:07 PM

Yes I can rebuild the project and I get no error but when I run debug this is the error I get. I also did a clean build as well. View the attachment for the error.

thank you

Royce Claborn

From: JoeStagner [mailto:notifications@codeplex.com]
Sent: Wednesday, May 05, 2010 8:01 AM
To: rcla39652@charter.net
Subject: Re: Need help I can't get sample app to work. [tailspinspyworks:211559]

From: JoeStagner

Did you try a clean rebuild ?

Read the full discussion online.

To add a post to this discussion, reply to this email (tailspinspyworks@discussions.codeplex.com)

To start a new discussion for this project, email tailspinspyworks@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com

Coordinator
May 5, 2010 at 3:35 PM

A hint is that tt looks like you've change directory structure around since the errror specifies...

C:\Users\DataSeek\Documents\Visual Studio 2010\Projects\Websites\BizDevTrainingVideos\BizDevTrainingVideos\Controls

 

May 5, 2010 at 4:08 PM

Okay I made a new folder and put all the files in as were in zip file. I make my reference to the Ajax toolkit v. 4.0 ran the rebuild project with now errors. I ran debug and the app started and then halted and gave me this error. If you need any more information let me know. I would sure like to get this working.

Thank you for your time.

Royce Claborn

System.NullReferenceException was unhandled by user code

  Message=Object reference not set to an instance of an object.

  Source=TailspinSpyworks

  StackTrace:

       at TailspinSpyworks.Global.Application_Error(Object sender, EventArgs e) in C:\Users\DataSeek\Documents\Visual Studio 2010\Projects\TailspinSpyworks\Global.asax.cs:line 28

       at System.EventHandler.Invoke(Object sender, EventArgs e)

       at System.Web.HttpApplication.RaiseOnError()

  InnerException:

From: JoeStagner [mailto:notifications@codeplex.com]
Sent: Wednesday, May 05, 2010 10:36 AM
To: rcla39652@charter.net
Subject: Re: Need help I can't get sample app to work. [tailspinspyworks:211559]

From: JoeStagner

A hint is that tt looks like you've change directory structure around since the errror specifies...

C:\Users\DataSeek\Documents\Visual Studio 2010\Projects\Websites\BizDevTrainingVideos\BizDevTrainingVideos\Controls

Read the full discussion online.

To add a post to this discussion, reply to this email (tailspinspyworks@discussions.codeplex.com)

To start a new discussion for this project, email tailspinspyworks@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com

May 5, 2010 at 4:11 PM

Here is another attachment. Hope it helps

From: JoeStagner [mailto:notifications@codeplex.com]
Sent: Wednesday, May 05, 2010 10:36 AM
To: rcla39652@charter.net
Subject: Re: Need help I can't get sample app to work. [tailspinspyworks:211559]

From: JoeStagner

A hint is that tt looks like you've change directory structure around since the errror specifies...

C:\Users\DataSeek\Documents\Visual Studio 2010\Projects\Websites\BizDevTrainingVideos\BizDevTrainingVideos\Controls

Read the full discussion online.

To add a post to this discussion, reply to this email (tailspinspyworks@discussions.codeplex.com)

To start a new discussion for this project, email tailspinspyworks@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com

Coordinator
May 5, 2010 at 4:39 PM

Can you tell me what the ACTUAL exception is ?

May 5, 2010 at 4:50 PM

If you have as way of doing it, I can let you come into my computer and try to fix the problem.

Royce

From: JoeStagner [mailto:notifications@codeplex.com]
Sent: Wednesday, May 05, 2010 11:40 AM
To: rcla39652@charter.net
Subject: Re: Need help I can't get sample app to work. [tailspinspyworks:211559]

From: JoeStagner

Can you tell me what the ACTUAL exception is ?

Read the full discussion online.

To add a post to this discussion, reply to this email (tailspinspyworks@discussions.codeplex.com)

To start a new discussion for this project, email tailspinspyworks@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com

May 5, 2010 at 5:52 PM

It appears to be working now.

Thanks for your help

Royce

From: JoeStagner [mailto:notifications@codeplex.com]
Sent: Wednesday, May 05, 2010 11:40 AM
To: rcla39652@charter.net
Subject: Re: Need help I can't get sample app to work. [tailspinspyworks:211559]

From: JoeStagner

Can you tell me what the ACTUAL exception is ?

Read the full discussion online.

To add a post to this discussion, reply to this email (tailspinspyworks@discussions.codeplex.com)

To start a new discussion for this project, email tailspinspyworks@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com

Coordinator
May 5, 2010 at 5:59 PM

What was the problem ?

May 5, 2010 at 6:58 PM

Not sure I shutdown VS and started it back up again and viewed it in the browser and it worked fine.

Royce

From: JoeStagner [mailto:notifications@codeplex.com]
Sent: Wednesday, May 05, 2010 1:00 PM
To: rcla39652@charter.net
Subject: Re: Need help I can't get sample app to work. [tailspinspyworks:211559]

From: JoeStagner

What was the problem ?

Read the full discussion online.

To add a post to this discussion, reply to this email (tailspinspyworks@discussions.codeplex.com)

To start a new discussion for this project, email tailspinspyworks@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com

May 6, 2010 at 7:02 PM

Will this app work on 2003 server with sql 2005 server?

Royce

From: JoeStagner [mailto:notifications@codeplex.com]
Sent: Wednesday, May 05, 2010 1:00 PM
To: rcla39652@charter.net
Subject: Re: Need help I can't get sample app to work. [tailspinspyworks:211559]

Read the full discussion online.

To add a post to this discussion, reply to this email (tailspinspyworks@discussions.codeplex.com)

To start a new discussion for this project, email tailspinspyworks@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com

Coordinator
May 10, 2010 at 1:07 PM

It should work fine.

May 10, 2010 at 6:35 PM

Well I have two things to ask about. I try to attach the database to sql2005 server I get a version conflict and want attach them.

The other thing is on the developer computer when I view it everything works fine, but when I publish it to the server nothing will work. It want even display the default page. I am sure that the server is setup right for the site. Well anyway I don't know what else to do to it.

thank you

rcla396

Coordinator
May 12, 2010 at 4:49 PM

You would have to migrate the database to 2005.